Benvenuto su Inforge
Rimuovi la pubblicità e partecipa alla più grande comunità italiana sul mondo digitale presente sul web sin dal 2007.
Iscriviti

Domanda Domanda sulle password degli archivi .zip

NoNameoN

Utente Gold
28 Marzo 2020
481
544
286
Ciao a tutti, come mai se creo un archivio .zip mettendo come password -1 mi da errore se provo a sbloccarlo e invece se provo a mettere 1- non da errore?
Si sa che operazione viene effettuata a riguardo?
Il primo carattere non può esserre il carattere -?
Oppure succede solo sul mio computer?
 

0xbro

Moderatore
24 Febbraio 2017
3,308
2,283
894
Ciao a tutti, come mai se creo un archivio .zip mettendo come password -1 mi da errore se provo a sbloccarlo e invece se provo a mettere 1- non da errore?
Si sa che operazione viene effettuata a riguardo?
Il primo carattere non può esserre il carattere -?
Oppure succede solo sul mio computer?
Io uso 7zip e non ho questo problema. Che software utilizzi?

Ho provato anche sia da una VM Kali che da una Debian 10 e non ho avuto problemi
 

NoNameoN

Utente Gold
28 Marzo 2020
481
544
286
In realtà uso quella in un certo senso "nativa" questa cosa mi è uscita usando Ubuntu sul pc di un mio collega

Creazione del file zip con password -1
1.png


Cosa mi esce quando provo ad aprire il file inserendo -1

2.png


Se provo ad aprirne uno con una password diversa non ho problemi
 
Supporta Inforge con una donazione
Supporta Inforge con un acquisto su NordVPN
18 Dicembre 2014
280
113
128
Secondo me è come se invece di inserire la password dessi un comando riferito a una directory che non esiste e manda errore. Non credo si tratti di un bug, ma di setting del pattern per espressione regolare di completamento del regex (non è una supercazzola, non sapevo come altrimenti spiegare).
 

NoNameoN

Utente Gold
28 Marzo 2020
481
544
286
Ultima modifica:
Secondo me è come se invece di inserire la password dessi un comando riferito a una directory che non esiste e manda errore. Non credo si tratti di un bug, ma di setting del pattern per espressione regolare di completamento del regex (non è una supercazzola, non sapevo come altrimenti spiegare).
Ho provato anche a usare altri caratteri speciali o combinazioni di cose ma funziona bene, solo se il primo carattere è - (meno) non va.. boh sarebbe interessante sapere cosa succede
Messaggio unito automaticamente:

Ecco un video dimostrativo fatto al volo

 
Supporta Inforge con una donazione
Supporta Inforge con un acquisto su NordVPN

NoNameoN

Utente Gold
28 Marzo 2020
481
544
286
Ultima modifica:
servirebbe sapere almeno la versione di ubuntu per poter fare ulteriori analisi
Ubuntu 21.04 64-bit
Messaggio unito automaticamente:

L'ho appena provato su una macchina virtuale nel mio pc e mi da lo stesso problema
 
  • Grazie
Reactions: 0xbro