Domanda Cloudflare_resolver not found-Websploit

Psychonaut

Utente Emerald
17 Giugno 2012
1,194
524
423
Ultima modifica:
sto smanettando con Websploit, e provando ad usare il modulo cloudflare mi torna l'errore nel titolo(in pratica non esiste nessuno script per cloudfare della directory contenente i moduli), c'è un modo per scaricare dei moduli aggiuntivi che voi sappiate?
il SO è Parrot security.
Ho anche provato ad usare questo ma mi da degli errori di sintassi(mancano le parentesi sui Print, ho provato ad aggiungerle ma da altri errori), ho anche provato a copiare il modulo interessato nella cartella dei moduli del Websploit installato di default ma all'avvio ritorna sempre l'errore delle parentesi sullo script.


In alternativa dovrei provare a scaricare Websploit dai repo di kali o di Ubuntu...
 

Hydralisca

Utente Electrum
31 Luglio 2014
341
33
128
Se fai una ricerca su github troverai altri script in grado di fare quello che cerchi, a patto che il dominio sia stato protetto da cloudflare in seguito e non subito dopo la sua creazione.
 

Psychonaut

Utente Emerald
17 Giugno 2012
1,194
524
423
Se intendi "cerca altri programmi che facciano la stessa cosa" ho già adocchiato altri programmi, ma vorrei capire e risolvere il problema che riscontro.
Cmq in serata provo i repo di kali e Ubuntu.
 
DOWNLOAD
Supporta Inforge con una donazione

0xbro

Moderatore
24 Febbraio 2017
3,468
2,588
959
Di default su Kali c'è ben poco, il tool l'ho installato questa mattina e non offre granchè...
Codice:
┌──(kali㉿kali)-[~]
└─$ websploit                 
[*] Internal update/upgrade system is disabled on Debian systems. Please, use the update system provided by your distro.

    ____    __    ____
    \   \  /  \  /   /     |    Welcome to Websploit
     \   \/    \/   /      |    Version : 4.0.4
      \            /       |    https://github.com/websploit/websploit
       \    /\    /        |    Author : Fardin Allahverdinazhand
        \__/  \__/         |    Codename : Reborn

    
    
wsf > show
Modules                 Description         
--------------------    --------------------------
arp_spoof               ARP Cache poisoning
http_sniffer            Sniff HTTP traffic
scan_network            Scan IP range for new devices
scan_wifi               Scan Wireless devices
wifi_deauth             Force device to disconnect from WIFI - De-authentication attack
wifi_fap                Start Fake Access point (AP)
wifi_fap_spam           Spamming Fake access points

Ho provato a inserire il modulo a mano all'interno della directory modules ma essendo scritto in python2 a websploit proprio non piace (ho notato che tutti i moduli presenti sono in python3, probabilmente non è stato fatto il porting dei vecchi moduli).
 
  • Mi piace
Reactions: LinuxUser

Psychonaut

Utente Emerald
17 Giugno 2012
1,194
524
423
Ultima modifica:
Infatti ho aperto un Issue sul loro GitHub, chiedendo appunto se questa funzione fosse ancora supportata.
Cercherò qualcos'altro su GitHub
Messaggio unito automaticamente:

Ho ripiegato su Cloudmare nel frattempo
 
  • Mi piace
Reactions: Hydralisca e 0xbro